$re = '/((?:|\s)\w+(?:\.|))(?:|,|\.)\s(\d+)/m';
$str = 'Av. Moinho Fabrini, 600 - Independencia, Sao Bernardo do Campo - SP, 09862-160
SAO BERNARDO DO CAMPO STATE OF SAO PAULO BRAZIL RUA VICENTE DE CARVALHO 197 09726 600
RUA JOAO PESSOA, 420, CENTRO, SAO BERNARDO DO CAMPO - SAO PAULO, 09715-000, BRASIL
AV. ROBERT KENNEDY. 3095 - ASSUNCAO SAO BERNARDO DO CAMPO - SP. 09860-215';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);