using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({\n*\s*""r"": \w+,\n*\s*""g"": \w+,\n*\s*""b"": \w+\n*\s*})";
string input = @" {
""object1"": {
""subobject1"": {
""r"": 0,
""g"": 0,
""b"": 0
},
""someOtherProperty"": 1
},
""allColors"": {
""object2"": [
{
""subobject2"": {
""r"": 4,
""g"": 5,
""b"": 6
},
""subobject3"": {
""r"": 7,
""g"": 8,
""b"": 9
},
""subobject4"": {
""r"": 9,
""g"": 10,
""b"": 11
}
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}