# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"({\n*\s*\"r\": \w+,\n*\s*\"g\": \w+,\n*\s*\"b\": \w+\n*\s*})"
test_str = (" {\n"
" \"object1\": {\n"
" \"subobject1\": {\n"
" \"r\": 0,\n"
" \"g\": 0,\n"
" \"b\": 0\n"
" },\n"
" \"someOtherProperty\": 1\n"
" },\n"
" \"allColors\": {\n"
" \"object2\": [\n"
" {\n"
" \"subobject2\": {\n"
" \"r\": 4,\n"
" \"g\": 5,\n"
" \"b\": 6\n"
" },\n"
" \"subobject3\": {\n"
" \"r\": 7,\n"
" \"g\": 8,\n"
" \"b\": 9\n"
" },\n"
" \"subobject4\": {\n"
" \"r\": 9,\n"
" \"g\": 10,\n"
" \"b\": 11\n"
" }\n"
" }\n"
" }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.