const regex = /({\n*\s*"r": \w+,\n*\s*"g": \w+,\n*\s*"b": \w+\n*\s*})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({\\n*\\s*"r": \\w+,\\n*\\s*"g": \\w+,\\n*\\s*"b": \\w+\\n*\\s*})', 'gm')
const str = ` {
"object1": {
"subobject1": {
"r": 0,
"g": 0,
"b": 0
},
"someOtherProperty": 1
},
"allColors": {
"object2": [
{
"subobject2": {
"r": 4,
"g": 5,
"b": 6
},
"subobject3": {
"r": 7,
"g": 8,
"b": 9
},
"subobject4": {
"r": 9,
"g": 10,
"b": 11
}
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}