$re = '/({\n*\s*"r": \w+,\n*\s*"g": \w+,\n*\s*"b": \w+\n*\s*})/m';
$str = ' {
"object1": {
"subobject1": {
"r": 0,
"g": 0,
"b": 0
},
"someOtherProperty": 1
},
"allColors": {
"object2": [
{
"subobject2": {
"r": 4,
"g": 5,
"b": 6
},
"subobject3": {
"r": 7,
"g": 8,
"b": 9
},
"subobject4": {
"r": 9,
"g": 10,
"b": 11
}
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);