using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\/\*\*";
string input = @"//**
******************************************************************************************
*
******************************************************************************************
*/
ModbusArray[0].Data = (int*) &LoopTime; // рег.0 Максиальный цикл программы
ModbusArray[0].WriterLock = RECORDING_IS_PROHIBITED;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}