$re = '/\/\/\*\*/m';
$str = '//**
******************************************************************************************
*
******************************************************************************************
*/
ModbusArray[0].Data = (int*) &LoopTime; // рег.0 Максиальный цикл программы
ModbusArray[0].WriterLock = RECORDING_IS_PROHIBITED;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);