package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)[^\s.,\/\\()]+`)
var str = `Имеется строка текста, слова в которой могут принадлежать различным алфавитам (латинскому, русскому, испанскому и т.д.). Слова могут разделяться как пробелами так и знаками пунктуации, переводами строки и т.п.
Как разбить такую строку на слова?
Пробовал использовать регулярное выражение /\b(\S+)\b/g , но оно корректно работает только с латинским алфавитом.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}