re = /[^\s.,\/\\()]+/im
str = 'Имеется строка текста, слова в которой могут принадлежать различным алфавитам (латинскому, русскому, испанскому и т.д.). Слова могут разделяться как пробелами так и знаками пунктуации, переводами строки и т.п.
Как разбить такую строку на слова?
Пробовал использовать регулярное выражение /\\b(\\S+)\\b/g , но оно корректно работает только с латинским алфавитом.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end