$re = '/[^\s.,\/\\\\()]+/im';
$str = 'Имеется строка текста, слова в которой могут принадлежать различным алфавитам (латинскому, русскому, испанскому и т.д.). Слова могут разделяться как пробелами так и знаками пунктуации, переводами строки и т.п.
Как разбить такую строку на слова?
Пробовал использовать регулярное выражение /\\b(\\S+)\\b/g , но оно корректно работает только с латинским алфавитом.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);