import Foundation
let pattern = #"[^\s.,\/\\()]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Имеется строка текста, слова в которой могут принадлежать различным алфавитам (латинскому, русскому, испанскому и т.д.). Слова могут разделяться как пробелами так и знаками пунктуации, переводами строки и т.п.
Как разбить такую строку на слова?
Пробовал использовать регулярное выражение /\b(\S+)\b/g , но оно корректно работает только с латинским алфавитом.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)