package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*\([^()\r\n]*\)[^()\r\n]*$`)
var str = `Artist - Title (12") (Warner Bros - WB1210)
Artist - Title (12", Promo) (Warner Bros - WB1212)
Artist - Title (Summer Mix) (12", Promo) (Warner Bros - WB1444)
Artist - Title (12", LP Album) (Warner Bros- - WB9449)
Artist - Title (12", Red) (Warner Bros - WB1211)
Artist - Title`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}