// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\([^()\r\n]*\)[^()\r\n]*$").unwrap();
let string = "Artist - Title (12\") (Warner Bros - WB1210)
Artist - Title (12\", Promo) (Warner Bros - WB1212)
Artist - Title (Summer Mix) (12\", Promo) (Warner Bros - WB1444)
Artist - Title (12\", LP Album) (Warner Bros- - WB9449)
Artist - Title (12\", Red) (Warner Bros - WB1211)
Artist - Title";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}