const regex = /\s*\([^()\r\n]*\)[^()\r\n]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\([^()\\r\\n]*\\)[^()\\r\\n]*$', 'gm')
const str = `Artist - Title (12") (Warner Bros - WB1210)
Artist - Title (12", Promo) (Warner Bros - WB1212)
Artist - Title (Summer Mix) (12", Promo) (Warner Bros - WB1444)
Artist - Title (12", LP Album) (Warner Bros- - WB9449)
Artist - Title (12", Red) (Warner Bros - WB1211)
Artist - Title`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);