$re = '/\s*\([^()\r\n]*\)[^()\r\n]*$/m';
$str = 'Artist - Title (12") (Warner Bros - WB1210)
Artist - Title (12", Promo) (Warner Bros - WB1212)
Artist - Title (Summer Mix) (12", Promo) (Warner Bros - WB1444)
Artist - Title (12", LP Album) (Warner Bros- - WB9449)
Artist - Title (12", Red) (Warner Bros - WB1211)
Artist - Title';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;