const regex = /^[\x{4E00}-\x{9FA5}a-z0-9_-]{3,6}$/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\x{4E00}-\\x{9FA5}a-z0-9_-]{3,6}$', 'u')
const str = `fhg中文`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}