import re
regex = re.compile(r"^[\x{4E00}-\x{9FA5}a-z0-9_-]{3,6}$", flags=re.UNICODE)
test_str = "fhg中文"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")