$re = '/^[\x{4E00}-\x{9FA5}a-z0-9_-]{3,6}$/u';
$str = 'fhg中文';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);