#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+(?:aa|bb))+(?:\dcc)+$"
Local $sString = "1bb2aa3aa4bb5bb6aa7bb8cc9cc" & @CRLF & _
"" & @CRLF & _
"1bb2aa3aa4bb5bb6aa7bb8cc9bb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")