$re = '/^(?:\d+(?:aa|bb))+(?:\dcc)+$/m';
$str = '1bb2aa3aa4bb5bb6aa7bb8cc9cc
1bb2aa3aa4bb5bb6aa7bb8cc9bb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);