use strict;
my $str = '1bb2aa3aa4bb5bb6aa7bb8cc9cc
1bb2aa3aa4bb5bb6aa7bb8cc9bb';
my $regex = qr/^(?:\d+(?:aa|bb))+(?:\dcc)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}