// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d+(?:aa|bb))+(?:\dcc)+$").unwrap();
let string = "1bb2aa3aa4bb5bb6aa7bb8cc9cc
1bb2aa3aa4bb5bb6aa7bb8cc9bb";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}