using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\S+\s*){6}";
string input = @"aaa
bbb
ccc
aaa bbb ccc
ddd eee fff ddd eee fff
ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff
ddd eee
ddd eee fff
ddd eee fff
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}