re = /(?:\S+\s*){6}/m
str = 'aaa
bbb
ccc
aaa bbb ccc
ddd eee fff ddd eee fff
ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff
ddd eee
ddd eee fff
ddd eee fff
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end