package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\S+\s*){6}`)
var str = `aaa
bbb
ccc
aaa bbb ccc
ddd eee fff ddd eee fff
ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff
ddd eee
ddd eee fff
ddd eee fff
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}