$re = '/(?:\S+\s*){6}/m';
$str = 'aaa
bbb
ccc
aaa bbb ccc
ddd eee fff ddd eee fff
ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff
ddd eee
ddd eee fff
ddd eee fff
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);