$re = '/python.*$/m';
$str = '/opt/homebrew/bin/python3
/usr/local/bin/python3
/usr/bin/python3
/usr/local/bin/python3.9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);