#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\s*a\s*[^<]*?>[^>]*>?<\s*\/a\s*>"
Local $sString = "<p>This is a test piece of text that contains the keywords in my array like <a>Photos</a>, C.V., CV, <a>Google</a>, <a>Github</a>, <a>Portfolio</a>,</a> Instagram, <a>email</a> and Simon, <a>ign <a oring the keywords if they're existing <a href="#>">Simon links</a>.</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")