package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\s*a\s*[^<]*?>[^>]*>?<\s*\/a\s*>`)
var str = `<p>This is a test piece of text that contains the keywords in my array like <a>Photos</a>, C.V., CV, <a>Google</a>, <a>Github</a>, <a>Portfolio</a>,</a> Instagram, <a>email</a> and Simon, <a>ign <a oring the keywords if they're existing <a href="#>">Simon links</a>.</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}