// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<\s*a\s*[^<]*?>[^>]*>?<\s*\/a\s*>").unwrap();
let string = "<p>This is a test piece of text that contains the keywords in my array like <a>Photos</a>, C.V., CV, <a>Google</a>, <a>Github</a>, <a>Portfolio</a>,</a> Instagram, <a>email</a> and Simon, <a>ign <a oring the keywords if they're existing <a href=\"#>\">Simon links</a>.</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}