const regex = /<\s*a\s*[^<]*?>[^>]*>?<\s*\/a\s*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*a\\s*[^<]*?>[^>]*>?<\\s*\\\/a\\s*>', 'gm')
const str = `<p>This is a test piece of text that contains the keywords in my array like <a>Photos</a>, C.V., CV, <a>Google</a>, <a>Github</a>, <a>Portfolio</a>,</a> Instagram, <a>email</a> and Simon, <a>ign <a oring the keywords if they're existing <a href="#>">Simon links</a>.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}