import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.+?:)|(\\(([^()]*)\\)$)";
final String string = "Trans of line: This is the (translation) of the line taken from the book (Tintin) comic book. Also take care of colon: coming in the text. (Tintin-Cigars of Pharoah)\n\n"
+ "Translation: This is the (translation) of the line taken from the book (Tintin) comic book. Also take care of colon: coming in the text. (Tintin)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}