import re
regex = re.compile(r"(^.+?:)|(\(([^()]*)\)$)", flags=re.MULTILINE)
test_str = ("Trans of line: This is the (translation) of the line taken from the book (Tintin) comic book. Also take care of colon: coming in the text. (Tintin-Cigars of Pharoah)\n\n"
"Translation: This is the (translation) of the line taken from the book (Tintin) comic book. Also take care of colon: coming in the text. (Tintin)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")