$re = '/(^.+?:)|(\(([^()]*)\)$)/m';
$str = 'Trans of line: This is the (translation) of the line taken from the book (Tintin) comic book. Also take care of colon: coming in the text. (Tintin-Cigars of Pharoah)
Translation: This is the (translation) of the line taken from the book (Tintin) comic book. Also take care of colon: coming in the text. (Tintin)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);