re = /(^.+?:)|(\(([^()]*)\)$)/m
str = 'Trans of line: This is the (translation) of the line taken from the book (Tintin) comic book. Also take care of colon: coming in the text. (Tintin-Cigars of Pharoah)
Translation: This is the (translation) of the line taken from the book (Tintin) comic book. Also take care of colon: coming in the text. (Tintin)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end