using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Wechsel nach Runlevel [12345]";
string input = @"Wechsel nach Runlevel 1
Wechsel nach Runlevel 2
Wechsel nach Runlevel 3
Wechsel nach Runlevel 4
Wechsel nach Runlevel 5
Wechsel nach Runlevel 6
Wechsel nach Runlevel 7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}