$re = '/Wechsel nach Runlevel [12345]/m';
$str = 'Wechsel nach Runlevel 1
Wechsel nach Runlevel 2
Wechsel nach Runlevel 3
Wechsel nach Runlevel 4
Wechsel nach Runlevel 5
Wechsel nach Runlevel 6
Wechsel nach Runlevel 7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);