import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Wechsel nach Runlevel [12345]";
final String string = "Wechsel nach Runlevel 1\n"
+ "Wechsel nach Runlevel 2\n"
+ "Wechsel nach Runlevel 3\n"
+ "Wechsel nach Runlevel 4\n"
+ "Wechsel nach Runlevel 5\n"
+ "Wechsel nach Runlevel 6\n"
+ "Wechsel nach Runlevel 7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}