import re
regex = re.compile(r"Wechsel nach Runlevel [12345]", flags=re.MULTILINE)
test_str = ("Wechsel nach Runlevel 1\n"
"Wechsel nach Runlevel 2\n"
"Wechsel nach Runlevel 3\n"
"Wechsel nach Runlevel 4\n"
"Wechsel nach Runlevel 5\n"
"Wechsel nach Runlevel 6\n"
"Wechsel nach Runlevel 7")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")