#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)(s1)(((?!s1|s2)(.|\n))*)(s2)"
Local $sString = "s1" & @CRLF & _
"s2" & @CRLF & _
"s1" & @CRLF & _
"s1" & @CRLF & _
"s2" & @CRLF & _
"s2" & @CRLF & _
"s1" & @CRLF & _
"s1" & @CRLF & _
"s2" & @CRLF & _
"s2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")