import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(s1)(((?!s1|s2)(.|\\n))*)(s2)";
final String string = "s1\n"
+ "s2\n"
+ "s1\n"
+ "s1\n"
+ "s2\n"
+ "s2\n"
+ "s1\n"
+ "s1\n"
+ "s2\n"
+ "s2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}