using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(s1)(((?!s1|s2)(.|\n))*)(s2)";
string input = @"s1
s2
s1
s1
s2
s2
s1
s1
s2
s2
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}