// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^").unwrap();
let string = "1111111
1111111
1111111";
let substitution = "dc.l 0b";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}