import Foundation
let pattern = #"^"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1111111
1111111
1111111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"dc.l 0b"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)