#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "import\s+(?:(?:([A-z_$][\w$]*)|\*\s+as\s+([A-z_$][\w$]*)|({\s*[A-z_$][\w$]*(?:\s+as\s+[A-z_$][\w$]*)?\s*(?:,\s*[A-z_$][\w$]*(?:\s+as\s+[A-z_$][\w$]*)?\s*)?}))\s+from\s+(("|'|`).*\5)|(("|'|`).*\7))"
Local $sString = "import defaultExport from "module-name";" & @CRLF & _
"import * as name from "module-name";" & @CRLF & _
"import { export1 } from "module-name";" & @CRLF & _
"import { export1 as alias1 } from "module-name";" & @CRLF & _
"import { export1 , export2 } from "module-name";" & @CRLF & _
"import { foo , bar } from "module-name/path/to/specific/un-exported/file";" & @CRLF & _
"import { export1 , export2 as alias2 } from "module-name";" & @CRLF & _
"import defaultExport, { export1 } from "module-name";" & @CRLF & _
"import defaultExport, * as name from "module-name";" & @CRLF & _
"import "module-name";" & @CRLF & _
"const module = await import("module-name");"
Local $sSubst = "const $1$2$3 = require($4)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)