import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "import\\s+(?:(?:([A-z_$][\\w$]*)|\\*\\s+as\\s+([A-z_$][\\w$]*)|(\\{\\s*[A-z_$][\\w$]*(?:\\s+as\\s+[A-z_$][\\w$]*)?\\s*(?:,\\s*[A-z_$][\\w$]*(?:\\s+as\\s+[A-z_$][\\w$]*)?\\s*)?\\}))\\s+from\\s+((\"|'|`).*\\5)|((\"|'|`).*\\7))";
final String string = "import defaultExport from \"module-name\";\n"
+ "import * as name from \"module-name\";\n"
+ "import { export1 } from \"module-name\";\n"
+ "import { export1 as alias1 } from \"module-name\";\n"
+ "import { export1 , export2 } from \"module-name\";\n"
+ "import { foo , bar } from \"module-name/path/to/specific/un-exported/file\";\n"
+ "import { export1 , export2 as alias2 } from \"module-name\";\n"
+ "import defaultExport, { export1 } from \"module-name\";\n"
+ "import defaultExport, * as name from \"module-name\";\n"
+ "import \"module-name\";\n"
+ "const module = await import(\"module-name\");";
final String subst = "const $1$2$3 = require($4)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}