# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"import\s+(?:(?:([A-z_$][\w$]*)|\*\s+as\s+([A-z_$][\w$]*)|({\s*[A-z_$][\w$]*(?:\s+as\s+[A-z_$][\w$]*)?\s*(?:,\s*[A-z_$][\w$]*(?:\s+as\s+[A-z_$][\w$]*)?\s*)?}))\s+from\s+((\"|'|`).*\5)|((\"|'|`).*\7))"
test_str = ("import defaultExport from \"module-name\";\n"
"import * as name from \"module-name\";\n"
"import { export1 } from \"module-name\";\n"
"import { export1 as alias1 } from \"module-name\";\n"
"import { export1 , export2 } from \"module-name\";\n"
"import { foo , bar } from \"module-name/path/to/specific/un-exported/file\";\n"
"import { export1 , export2 as alias2 } from \"module-name\";\n"
"import defaultExport, { export1 } from \"module-name\";\n"
"import defaultExport, * as name from \"module-name\";\n"
"import \"module-name\";\n"
"const module = await import(\"module-name\");")
subst = "const $1$2$3 = require($4)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.