const regex = /import\s+(?:(?:([A-z_$][\w$]*)|\*\s+as\s+([A-z_$][\w$]*)|({\s*[A-z_$][\w$]*(?:\s+as\s+[A-z_$][\w$]*)?\s*(?:,\s*[A-z_$][\w$]*(?:\s+as\s+[A-z_$][\w$]*)?\s*)?}))\s+from\s+(("|'|`).*\5)|(("|'|`).*\7))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('import\\s+(?:(?:([A-z_$][\\w$]*)|\\*\\s+as\\s+([A-z_$][\\w$]*)|({\\s*[A-z_$][\\w$]*(?:\\s+as\\s+[A-z_$][\\w$]*)?\\s*(?:,\\s*[A-z_$][\\w$]*(?:\\s+as\\s+[A-z_$][\\w$]*)?\\s*)?}))\\s+from\\s+(("|\'|`).*\\5)|(("|\'|`).*\\7))', 'g')
const str = `import defaultExport from "module-name";
import * as name from "module-name";
import { export1 } from "module-name";
import { export1 as alias1 } from "module-name";
import { export1 , export2 } from "module-name";
import { foo , bar } from "module-name/path/to/specific/un-exported/file";
import { export1 , export2 as alias2 } from "module-name";
import defaultExport, { export1 } from "module-name";
import defaultExport, * as name from "module-name";
import "module-name";
const module = await import("module-name");`;
const subst = `const $1$2$3 = require($4)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);