#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!www.(?:abc|def).test.com)(?=www.*\.test\..*com)^.+$"
Local $sString = "www.test.com" & @CRLF & _
"www.abc.test.com" & @CRLF & _
"www.def.test.com" & @CRLF & _
"www.ghi.test.com" & @CRLF & _
"www.nottest.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")