re = /(?!www.(?:abc|def).test.com)(?=www.*\.test\..*com)^.+$/m
str = 'www.test.com
www.abc.test.com
www.def.test.com
www.ghi.test.com
www.nottest.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end